Богон IP-детектор
Проверьте, не является ли какой-либо IP-адрес богонским (марсианским) адресом — IP-адресом, который никогда не должен появляться в общедоступном Интернете. Введите адрес IPv4 или IPv6, чтобы сразу увидеть, попадает ли он в частный (RFC 1918), кольцевой, локальный, многоадресный, CGNAT, документационный, зарезервированный или другие специальные диапазоны. Все обнаружение происходит локально в вашем браузере с полной конфиденциальностью — регистрация не требуется.
Enter any IP address to instantly check if it is a bogon (martian) address - an IP that should never appear on the public internet. Detects all major bogon ranges per RFC standards. All processing happens locally in your browser.
Enter an IP address above to check if it is a bogon
Click any example button to test with a sample IP address
Зачем использовать наш IP-детектор Bogon?
- Мгновенное обнаружение богонов: введите любой адрес IPv4 или IPv6 и мгновенно определите, является ли это адресом богонов (марсианских). Наш инструмент проверяет все основные диапазоны IP-адресов богонов, определенные в стандартах RFC, включая частные (RFC 1918), петлевые, локальные, многоадресные, широковещательные, CGNAT, документацию, бенчмаркинг и зарезервированные диапазоны.
- Комплексный охват диапазона: охватывает все известные диапазоны адресов как для IPv4, так и для IPv6. Проверки богона IPv4 включают 14 различных диапазонов из RFC 1122, 1918, 5737, 6598, 2544, 5771 и других. Проверки богона IPv6 включают 10 диапазонов из RFC 4291, 4193, 3849, 3056, 4380 и других. Новые диапазоны добавляются по мере развития стандартов.
- Классификация на основе серьезности: каждый диапазон богонов классифицируется по уровню серьезности: высокий (критические угрозы безопасности, такие как частные IP-адреса в общедоступном Интернете), средний (важный, но менее критичный, например CGNAT), низкий (адреса специального назначения) и информационный (адреса с конкретным контекстом, например 6to4). Помогает вам расставить приоритеты в действиях по обеспечению безопасности.
- 100% конфиденциальность и клиентская сторона: все проверки IP-адреса выполняются полностью в вашем браузере с использованием JavaScript. Введенные вами IP-адреса никогда не покидают ваше устройство — ни загрузка, ни обработка на сервере, ни журналирование. Ваши сетевые данные всегда остаются полностью конфиденциальными и безопасными.
Распространенные случаи использования IP-детектора Bogon
- Аудит сетевой безопасности. Аудит конфигураций брандмауэра и маршрутизатора путем проверки блокировки IP-адресов богонов по периметру. Убедитесь, что частные адреса RFC 1918, диапазоны обратной связи и другие марсианские адреса не достигают ваших общедоступных сетевых интерфейсов.
- Обслуживание списков фильтров богонов: при ведении списков фильтров богонов для сетевой инфраструктуры (фильтры префиксов BGP, правила ACL, iptables, nftables) используйте этот инструмент для проверки отдельных IP-адресов на соответствие текущим диапазонам богонов, чтобы убедиться, что ваши фильтры работают правильно.
- Проверка IP-адреса в приложениях. Перед обработкой проверяйте IP-адреса в ваших приложениях, чтобы убедиться, что они являются законными общедоступными адресами. Проверьте предоставленные пользователем IP-адреса, списки управления доступом на основе IP или IP-адреса из внешних источников данных, чтобы отфильтровать богон-адреса.
- Диагностика сети и устранение неполадок. При устранении проблем с сетевым подключением проверьте, не являются ли неожиданные IP-адреса в ваших журналах адресами богонов. Это помогает выявить неправильно настроенные устройства, петли маршрутизации или потенциальные попытки подмены в вашей сети.
- Расследование инцидентов безопасности. Во время расследования инцидентов безопасности проверяйте исходные IP-адреса из журналов по диапазонам богонов, чтобы выявить потенциально поддельные или поддельные IP-адреса. Адреса источников Bogon в журналах атак часто указывают на подмену IP-адреса или атаки с отражением.
- Операции интернет-провайдеров и центров обработки данных: сетевые операторы могут использовать детектор богонов, чтобы убедиться, что трафик клиентов не поступает с адресов богонов и не направляется на них. Необходим для обеспечения соответствия требованиям BCP 38 (сетевая фильтрация входящего трафика) и предотвращения подмены IP-адресов в сетевой инфраструктуре.
Что такое IP-адрес Богона?
IP-адрес богона (также называемый марсианским адресом) — это IP-адрес, который никогда не должен появляться в общедоступном Интернете. Эти адреса зарезервированы Управлением по присвоению номеров в Интернете (IANA) для специальных целей, таких как частные сети, интерфейсы обратной связи, многоадресная рассылка, документация, тестирование или использование в будущем. Термин «богон» происходит от «фильтрации богонов» — практики фильтрации пакетов с явно неверными адресами источника или назначения на границах сети.
Когда пакет с адресом источника богона появляется в общедоступном Интернете, это часто указывает на подделку IP-адреса, неправильно настроенный маршрутизатор или инцидент сетевой безопасности. Интернет-провайдеры, центры обработки данных и корпоративные сети реализуют богон-фильтрацию в рамках передового опыта BCP 38 (фильтрация сетевого входа) для предотвращения подделки и повышения сетевой безопасности.
Как работает наш IP-детектор Bogon
Наш детектор богонов проверяет IP-адреса на соответствие полным спискам известных диапазонов адресов богонов, определенных несколькими стандартами RFC.
- Анализ IPv4 — IP-адрес преобразуется в 32-битное целое число и проверяется по 14 различным диапазонам CIDR богона, включая частные сети (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16), петлевая проверка (127.0.0.0/8), CGNAT (100.64.0.0/10), локальная ссылка (169.254.0.0/16), многоадресная рассылка (224.0.0.0/4), диапазоны документации, диапазон тестирования и зарезервированное пространство.
- Анализ IPv6. Адрес IPv6 расширяется из сжатой формы и проверяется по 10 диапазонам специального назначения, включая неуказанный адрес (::/128), петлю (::1/128), уникальный локальный (fc00::/7), локальный канал (fe80::/10), многоадресную рассылку (ff00::/8), документацию (2001:db8::/32) и другие, такие как 6to4 и Туннель Тередо.
- Классификация серьезности. Каждому обнаруженному диапазону богонов помечен уровень серьезности: высокий (критический — никогда не должен быть виден), средний (важный — ограниченные варианты использования), низкий (специального назначения — зависит от контекста) или информационный (информационный — необычный, но не обязательно вредоносный).
Распространенные ареалы богонов и их использование
Наш детектор богонов проверяет следующие основные категории адресов:
- Частные сети (RFC 1918). Три частных диапазона IPv4 (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16) и уникальные локальные адреса IPv6 (fc00::/7) являются наиболее часто встречающимися диапазонами богонов. Они действительны в частных сетях, но должны фильтроваться на границах Интернета.
- Loopback & Link-Local — адреса Loopback (127.0.0.0/8, ::1) используются для связи с локальным хостом. Локальные адреса каналов (169.254.0.0/16, fe80::/10) назначаются автоматически и никогда не маршрутизируются. Оба относятся к диапазонам богонов высокой степени тяжести.
- Документация и тестирование — диапазоны TEST-NET (192.0.2.0/24, 198.51.100.0/24, 203.0.113.0/24) и префикс IPv6 документации (2001:db8::/32) зарезервированы для документации и примеров. Диапазон тестирования (198.18.0.0/15) используется инструментами сетевого тестирования.
- Многоадресная и зарезервированная — диапазоны многоадресной рассылки (224.0.0.0/4, ff00::/8) предназначены для доставки «один ко многим», а не для одноадресной маршрутизации. Зарезервированный диапазон (240.0.0.0/4, ранее класс E) зарезервирован для будущего использования IANA.
Конфиденциальность и безопасность
Все действия по обнаружению богонов полностью выполняются в вашем браузере с использованием JavaScript. Введенные вами IP-адреса никогда не отправляются на какой-либо сервер, никогда не сохраняются в какой-либо базе данных и никогда не покидают ваше устройство. Это обеспечивает полную конфиденциальность при проверке внутренних сетевых адресов, частных IP-адресов или любых других адресов, которые вы решите проверить.
Инструмент работает полностью в автономном режиме после начальной загрузки страницы. Никакие данные не регистрируются, никакая аналитика не отслеживает ваши запросы, и ни один сервер не обрабатывает ваши входные данные. Информация о вашей сети остается только вашей.
Часто задаваемые вопросы
IP-адрес богона (также называемый марсианским адресом) — это IP-адрес, который никогда не должен появляться в общедоступном Интернете. Эти адреса зарезервированы IANA для специальных целей, таких как частные сети, интерфейсы обратной связи, многоадресная рассылка, документация или использование в будущем. Термин «богон» часто используется в контексте сетевой безопасности для описания пакетов, которые имеют явно неверные адреса источника или назначения.
Фильтрация адресов богонов является важной передовой практикой сетевой безопасности (BCP 38). Фильтрация Богона предотвращает подделку IP-адресов, снижает риск атак с отражением DDoS, останавливает трафик из неправильно настроенных сетей и помогает поддерживать чистоту таблиц маршрутизации. Большинство интернет-провайдеров и крупных сетей реализуют богон-фильтрацию на своих пограничных маршрутизаторах.
Частные IP-адреса (RFC 1918) представляют собой подмножество адресов богонов. Все частные IP-адреса являются богонами, но не все богоны являются частными IP-адресами. Адреса Богона включают частные диапазоны, петлевые адреса, локальные адреса, многоадресную рассылку, широковещательные диапазоны, диапазоны документации, зарезервированное пространство и адреса специального назначения IPv6.
Абсолютно. Вся проверка IP-адреса выполняется полностью в вашем браузере с использованием клиентского JavaScript. Введенные вами IP-адреса никогда не отправляются на какой-либо сервер, никогда не сохраняются в какой-либо базе данных и никогда не покидают ваше устройство. Инструмент работает полностью в автономном режиме после начальной загрузки страницы.
Да. Наш IP-детектор Bogon полностью поддерживает адреса IPv4 и IPv6. Для IPv6 он обнаруживает 10 диапазонов специального назначения, включая неуказанный адрес, обратную связь, адреса, сопоставленные с IPv4, трансляцию NAT64, префикс документации, 6to4, Teredo, уникальные локальные адреса, одноадресную и многоадресную рассылку по локальному каналу.
Высокая степень серьезности указывает на критические диапазоны богонов, которые никогда не следует видеть в общедоступном Интернете, например в частных сетях и кольцевой проверке. Средняя серьезность охватывает важные диапазоны, такие как CGNAT и документация. Низкая серьезность включает в себя адреса специального назначения, такие как многоадресная рассылка и тестирование. Информационные охватывают адреса, которые являются необычными, но могут иметь законные варианты использования.
Наиболее важными диапазонами богонов для фильтрации являются частные диапазоны RFC 1918 (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16), петлевая связь (127.0.0.0/8), локальная ссылка (169.254.0.0/16), CGNAT. (100.64.0.0/10) и многоадресная рассылка (224.0.0.0/4). Они охватывают подавляющее большинство богон-трафика, наблюдаемого в общедоступном Интернете.
Да, наш Bogon IP Detector на 100% бесплатен, не требует регистрации, ограничений на использование и скрытых платежей. Проверяйте столько IP-адресов, сколько вам нужно — ограничений на количество запросов нет. Вся обработка происходит локально в вашем браузере.